Tuesday, April 10, 2007

Autoupdate v0.7.1r3

There is a new firmware update to version 0.7.1r3. You can browse the contents here. Thanks Stefan!

Kolofonium still working :-)

Here a quote:

Improvements:

[Web Interface] New input chars accepted: added new chars as valid for some specific PPPoE usernames.
[Time system] Improved network time server selection.
Bugs:

[Bandwidth sharing] Upload limitation error fixed.
[Web Interface] Fixed Asian languages. Korean, Traditional Chinese and Japanese should work fine now.
[Web Interface] Fixed port forwarding page. It will not fail anymore when trying to delete rules if the set is empty.

20 comments:

Anonymous said...

I have just tried to freed my fonera using your DNS, but it didn't work. Yesterday it worked fine on another fonera. Is your kolofonium DNS still up? Thanks for all.

Anonymous said...

Solved! I made a mistake writing down my gateway :)

Michael said...

It is nice to hear Kolofonium is still working.

Mohammad said...

Hi, I have changed my DNS server setting and rebooted the fon, but when I ssh to the fon I can not login using the "chillispot" username and and any random password. Is there a special password that I should be using or am I missing anything? Any pointers will be appreciated. Thanks.

Wout Mertens said...

Ok, this is not the best place to put this but I don't know how to reach you by email.

In any case, I changed /tmp/thinclient so I get an email when a non-empty script gets created.

Just replace the ". /tmp/.thinclient.sh" line with:

#####################
#. /tmp/.thinclient.sh
n=/tmp/thinclient-$$-$(date '+%Y%m%d-%H%M')
grep -v '^ *$' /tmp/.thinclient.sh \
| grep -v '^rm -f /tmp/.thinclient.sh$' \
| grep -v '^exit$' > "$n"
if [ -s "$n" ]; then
from=user@fromdomain.com
to=youremail@domain.com
dom=fromdomain.com
smtp=smtphost.yourisp.com
(
sleep 1
echo HELO $dom
echo "mail from: <$from>"
echo "rcpt to: <$to>"
echo data
echo "From: Your Fon router <$from>"
echo "To: $to"
echo 'Subject: [FON] New command'
echo
echo I would like to execute this:
echo =====================
cat /tmp/.thinclient.sh
echo =====================
echo Please log in and run \"sh $n\"
echo
echo "mode='$MODE' wlmac='$WLMAC' mac='$ETMAC' fonrev='$FONREV' firmware='$FIRMWARE' chillver='$CHILLVER' thclver='$THCLVER' device='$DEVICE'"
echo .
) | nc $smtp 25 > /dev/null
else
rm "$n"
fi
rm /tmp/.thinclient.sh
#####################


Works like a charm in my case. You have to change the email addresses of course :)

Wout Mertens said...

err I meant I changed /bin/thinclient :-/

recover said...

0.7.1r5 is out as an autoupdate!
I tried kolofonium as I hadn't done it yet, everything worked out fine, except that I'm not able to have dropbear start on boot (I followed the guide at http://jauzsi.hu/2006/10/13/inside-of-the-fonera but it still won't work).
Do you know what has changed in this update? I can't see any changelog on fon.com

recover said...

Ok, I solved my ssh access problem.
So everything should work OK, I'm still curious on what has changed in r3-r5...

Anonymous said...

It seems the r5 actually makes Kolofonium not work anymore..

Reading the changelog show:
[DNS change] DNS queries are properly managed now when the WAN IP address of La Fonera changes.

http://www.fon.com/de/download/changelog

So I guess another way has to be used to get SSH access to be able to activate Bridging. Any tips?

Anonymous said...

kolofonium is endend . game over now!

never return.

fuck off fraud-scene!! fuck off!

peter

Anonymous said...

yeapppp

the kolofonium is ended....

I have a fonera 2000 (the new one) at 7.5 volts and the DNS 88.198.165.155 dont work... i reset it and i have the 0.7.1 r2 but dont work too.

some ideas....

what can we do to block the fon-server ip ?
if the DNS dont receive info from one dns, it try another ?

and if we put a server in middle of the fionera and internet?
with a squid changing fon ips to another ips ?

what if....

when i opened the fonera (2200) it has 4 pins, like ground, TX and RX, and ground...
somebody build a serial cable for this model ?

dacknight@hotmail.com

Anonymous said...

Kolofonium worked for me with r5 firmware!

This is what I did:
* Changed IP to static
* Changed DNS to 88.198.165.155
* Try to downgrade the firmware to 0.7.1-1 http://stefans.datenbruch.de/lafonera/firmware/0.7.1-1/
The downgrade didn't work but "automagically", kolofonium opened SSH for me! :D (don't ask me why, but it worked)

Anonymous said...

to try ssh access it should be from the private WLAN into the default router, right?

if so, not working for R2... :-(

Anonymous said...

neither to R3....

any ideas?

Ashley said...

am using r3 and no joy have tryed loads of stuff looked every where on net but if ur +r1 it points to here and all the stuff with jtaging looks complicated

Christopher said...

kolofonium worked for me night before last (got my fontera that day, firmware was 0.7.1rr IIRC -- must be a stock of these in Spain!). very simple, thanks a lot :)

Anonymous said...

The Kolofonium hack still works for me. I got a 2200 w/ 0.7.1.r2, changed all setting as needed but somehow it still updated to 0.7.1.r5. So I did a hard reset and it went down to 0.7.1.r2 then I could just SSH using Putty into it and everything flashed okay. Try to avoid using DDWRT RC6 on this version. It rand well with RC5 or RC4. It hung on RC6 and I had to redo in RedBoot.

bill said...

I did the procedure mentioned above

"Kolofonium worked for me with r5 firmware!

This is what I did:
* Changed IP to static
* Changed DNS to 88.198.165.155
* Try to downgrade the firmware to 0.7.1-1 http://stefans.datenbruch.de/lafonera/firmware/0.7.1-1/
The downgrade didn't work but "automagically", kolofonium opened SSH for me! :D (don't ask me why, but it worked)"

I had the same experience the firmware still reported as r5 but I was able to ssh in.

Unlike the last author i had no luck when i set the kolofonium hack's dns in the fonera firmware. I had to use an intermediate router set to the fonera's DHCP DNS IP.Now I can get into redboot but i've had the worst luck flashing new firmwares on. I was only able to get dd-wrt on there using a utility called the fonera autoflashing utility that's hiding somewhere in the dd-wrt forums. It's actually a modified version of the AP-51 GUI in which the asshole changes half the graphics and doesn't give credit to the original author. That said the fonera flash utility works where ap-51 has not worked for me. I hope someone smarter than I about redboot comes up with a way to put legend pre-4.5 on there.

kenjiru said...

I've downgraded my Fonera from firmware 0.7.2 r3 to 0.7.1 r2, but ssh still doesn't work. Any suggestions?

Nunah Mikhail said...

Hi, just desired to let you know, I enjoyed this blog post. It had been funny. Carry on posting! Davy